$re = '/\/:[^\/]+/';
$str = '/foo/:some_id/bar/:id';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;