$re = '/([a-zA-Z]{3})([UJZujz])(\d{6})(\d)/';
$str = 'CAXU1234567';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);