$re = '/(\w+)=([\d|\w]+)(?=;|\"|\Z)/';
$str = 'nama=john; class=6; height=170; weight=70';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);