$re = '/\bfrom(?!\s*#)([^w]*(?:\bw(?!here\b)[^w]*)*)where/';
$str = 'select ... from course c
where id = (select ... from student where ...)
select ... from #bar
where id = (select ... from student where ...)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);