re = /\bfrom(?!\s*#)([^w]*(?:\bw(?!here\b)[^w]*)*)where/
str = 'select ... from course c
where id = (select ... from student where ...)
select ... from #bar
where id = (select ... from student where ...)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end