import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/|[a-z\\-\\d])*";
final String string = "/\n"
+ "/news\n"
+ "/news/\n"
+ "/news/sport\n"
+ "/news/sport/\n"
+ "/news/sport/12234\n"
+ "/news/sport/12234/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}