using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Hello\s*((?:(?!Hello|Rita).)*?)\s*Rita";
string input = @"Hello Mr John and Hello Ms Rita";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}