$re = '/Hello\s*((?:(?!Hello|Rita).)*?)\s*Rita/';
$str = 'Hello Mr John and Hello Ms Rita';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);