$re = '/((?:\[[^]]*\])+)/';
$str = 'This is my string [something: something] and the string is very pretty [something: something][a][b][c].';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);