#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)const.*=.*{+$"
Local $sString = "exports.async_createUser = async (user, required) => {" & @CRLF & _
"exports.async_createUser = async (user, required) => " & @CRLF & _
"" & @CRLF & _
"const test = function(a,b) => {" & @CRLF & _
"const test = (a,b) => {" & @CRLF & _
"const test = a => {" & @CRLF & _
"const async_getInfAuthToken = async () => {" & @CRLF & _
"const convertFromStateABV = async abv => {" & @CRLF & _
"const customField = infUser.custom_fields.filter(index => {" & @CRLF & _
"const thing = new user({" & @CRLF & _
"// const thing = new user({" & @CRLF & _
"// inf.updateWedding(weddingId);" & @CRLF & _
"inf.setMilestoneDate(req.user, 8);" & @CRLF & _
"}); //User email >> Spouse email (42)" & @CRLF & _
"exports.infCreate = function(req, callback) {" & @CRLF & _
"const user = await User.findOne({ _id: wedding.users[numUser] });" & @CRLF & _
"" & @CRLF & _
"const test = function(a,b) " & @CRLF & _
"const i = require(./stuff)" & @CRLF & _
"// const userC = require("./users");" & @CRLF & _
"" & @CRLF & _
"const User = require("./../models/user");" & @CRLF & _
"const Utils = require("./../utils");" & @CRLF & _
"const userC = require("./users");" & @CRLF & _
"const Wedding = require("./../models/wedding");" & @CRLF & _
"const config = require("./../config");" & @CRLF & _
"const request = require("request-promise");" & @CRLF & _
"const sms = require("./smss");" & @CRLF & _
"const email = require("./emails");" & @CRLF & _
"const contacts = require("./contacts");" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""error [inf.getNumberOfContactsFromWeddingID] : " + //" & @CRLF & _
"inf.applyTagToUser(userList[i].inf_id, [ //" & @CRLF & _
"// inf.setMilestoneDate(userList[i], 8);" & @CRLF & _
"inf.applyTagToUser(u.inf_id, [564]); //[Fulfillment _ 110 _ DLY _ LM _ WT - couples _ v01 _ START]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")