// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)const.*=.*{+$").unwrap();
let string = "exports.async_createUser = async (user, required) => {
exports.async_createUser = async (user, required) =>
const test = function(a,b) => {
const test = (a,b) => {
const test = a => {
const async_getInfAuthToken = async () => {
const convertFromStateABV = async abv => {
const customField = infUser.custom_fields.filter(index => {
const thing = new user({
// const thing = new user({
// inf.updateWedding(weddingId);
inf.setMilestoneDate(req.user, 8);
}); //User email >> Spouse email (42)
exports.infCreate = function(req, callback) {
const user = await User.findOne({ _id: wedding.users[numUser] });
const test = function(a,b)
const i = require(./stuff)
// const userC = require(\"./users\");
const User = require(\"./../models/user\");
const Utils = require(\"./../utils\");
const userC = require(\"./users\");
const Wedding = require(\"./../models/wedding\");
const config = require(\"./../config\");
const request = require(\"request-promise\");
const sms = require(\"./smss\");
const email = require(\"./emails\");
const contacts = require(\"./contacts\");
\"error [inf.getNumberOfContactsFromWeddingID] : \" + //
inf.applyTagToUser(userList[i].inf_id, [ //
// inf.setMilestoneDate(userList[i], 8);
inf.applyTagToUser(u.inf_id, [564]); //[Fulfillment _ 110 _ DLY _ LM _ WT - couples _ v01 _ START]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}