$re = '/(?s)\[\'(?<object>[^\']+)\'.*?setPosASL\s*(?<setPosASL>[^;]+).*? setVectorDirAndUp\s*(?<VectorDirAndUp>[^;]+)(?s-)/';
$str = '_newObject = createVehicle [\'Land_CncWall4_F\', [11459.2,11330.3,-0.000549316], [], 0, \'CAN_COLLIDE\'];
_newObject setPosASL [11459.4,11330.2,317.238];
_newObject setVectorDirAndUp [[0.790714,-0.612186,0], [0,0,1]];
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);