const regex = /videoBufferedMiliseconds\s+(\d+.?\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('videoBufferedMiliseconds\\s+(\\d+.?\\d+$)', 'gm')
const str = `2020 May 12 09:28:11.292856 arrisxi6 runAppManager.sh[28161]: 200512-09:28:11.277875 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 2015.234
2020 May 12 09:28:12.282703 arrisxi6 runAppManager.sh[28161]: 200512-09:28:12.281919 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 12025
2020 May 12 09:28:13.280853 arrisxi6 runAppManager.sh[28161]: 200512-09:28:13.280054 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 15029
2020 May 12 09:28:14.280813 arrisxi6 runAppManager.sh[28161]: 200512-09:28:14.280181 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 14029`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}