$re = '/videoBufferedMiliseconds\s+(\d+.?\d+$)/m';
$str = '2020 May 12 09:28:11.292856 arrisxi6 runAppManager.sh[28161]: 200512-09:28:11.277875 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 2015.234
2020 May 12 09:28:12.282703 arrisxi6 runAppManager.sh[28161]: 200512-09:28:12.281919 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 12025
2020 May 12 09:28:13.280853 arrisxi6 runAppManager.sh[28161]: 200512-09:28:13.280054 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 15029
2020 May 12 09:28:14.280813 arrisxi6 runAppManager.sh[28161]: 200512-09:28:14.280181 [mod=RDKBROWSER2, lvl=INFO] [tid=28787] onConsoleLog:rdkbrowser.cpp:1130 [ConsoleAPI:473]: Progress: videoBufferedMiliseconds 14029';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);