package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?'m'\b\w+\b)[\w\W]+\k'm'`)
var str = `ghbdtn kjfgkfjg fdkjsdlaj
kdfsjdlkjf kdjfkld ghbdtn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}