re = /^(?'m'\b\w+\b)[\w\W]+\k'm'/m
str = 'ghbdtn kjfgkfjg fdkjsdlaj
kdfsjdlkjf kdjfkld ghbdtn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end