using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$([a-zA-Z_]{1}[a-zA-Z0-9_]*)(?=\W)";
string input = @"(some txt)$aaa$bbb(another txt)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}