$re = '/\$([a-zA-Z_]{1}[a-zA-Z0-9_]*)(?=\W)/';
$str = '(some txt)$aaa$bbb(another txt)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);