const regex = new RegExp('^([a-zA-Z0-9]*)\\b(.+)\\b(\\1)$', 'gm')
const str = `phase3 allow buying in phase3 but
phase4 has no end
phase5 is test of phase
p`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}