$re = '~^([a-zA-Z0-9]*)\b(.+)\b(\1)$~m';
$str = 'phase3 allow buying in phase3 but
phase4 has no end
phase5 is test of phase
p';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);