re = /^((\d{1,2}(,\d{3})+)|(\d+)(\.\d{2})?)$/m
str = '10000000
10,000,000
10000000.00
10,000,000.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end