// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\d{1,2}(,\d{3})+)|(\d+)(\.\d{2})?)$").unwrap();
let string = "10000000
10,000,000
10000000.00
10,000,000.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}