import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^\\S\\r\\n]*[0-9]+[.][0-9]{2}[^\\S\\r\\n]*)\\n)*(([^\\S\\r\\n]*[0-9]+[.][0-9]{2}[^\\S\\r\\n]*))$";
final String string = "123.32 \n"
+ "234.54\n"
+ "456.43";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}