const regex = /^(([^\S\r\n]*[0-9]+[.][0-9]{2}[^\S\r\n]*)\n)*(([^\S\r\n]*[0-9]+[.][0-9]{2}[^\S\r\n]*))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([^\\S\\r\\n]*[0-9]+[.][0-9]{2}[^\\S\\r\\n]*)\\n)*(([^\\S\\r\\n]*[0-9]+[.][0-9]{2}[^\\S\\r\\n]*))$', 'g')
const str = `123.32
234.54
456.43`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}