import re
regex = re.compile(r"http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$", flags=re.IGNORECASE)
test_str = "http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")