import re
regex = re.compile(r"(http|https)?:\/\/(www\.)?vimeo.com\/(?:channels\/(?:\w+\/)?|groups\/([^\/]*)\/videos\/|)(\d+)(?:|\/\?)")
test_str = ("Vimeo Regex\n\n"
"# plain ok\n"
"https://vimeo.com/62092214\n"
"http://vimeo.com/62092214\n"
"https://www.vimeo.com/62092214\n\n"
"# plain not ok\n"
"http://vimeo/62092214\n"
"http://vimeo.com/foo\n\n"
"# channels ok:\n"
"https://vimeo.com/channels/documentaryfilm/128373915\n\n"
"# channels not ok:\n"
"https://vimeo.com/channels/foo-barr/documentaryfilm/128373915\n\n"
"# groups ok:\n"
"https://vimeo.com/groups/musicvideo/videos/126199390\n\n"
"# groups not ok:\n"
"http://vimeo.com/groups/musicvideo/vid/126199390\n\n"
"# attributes ok:\n"
"https://vimeo.com/62092214?query=foo\n\n"
"# attributes not ok:\n"
"https://vimeo.com.omomom/62092214?query=foo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")