// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http|https)?:\/\/(www\.)?vimeo.com\/(?:channels\/(?:\w+\/)?|groups\/([^\/]*)\/videos\/|)(\d+)(?:|\/\?)").unwrap();
let string = "Vimeo Regex
# plain ok
https://vimeo.com/62092214
http://vimeo.com/62092214
https://www.vimeo.com/62092214
# plain not ok
http://vimeo/62092214
http://vimeo.com/foo
# channels ok:
https://vimeo.com/channels/documentaryfilm/128373915
# channels not ok:
https://vimeo.com/channels/foo-barr/documentaryfilm/128373915
# groups ok:
https://vimeo.com/groups/musicvideo/videos/126199390
# groups not ok:
http://vimeo.com/groups/musicvideo/vid/126199390
# attributes ok:
https://vimeo.com/62092214?query=foo
# attributes not ok:
https://vimeo.com.omomom/62092214?query=foo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}