using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a[^abc]*b[^ac]*c";
string input = @"a zzz c
a zzz c --- b
a b c
a 000 a b c";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}