package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(P([1-9]|[1-9][0-9])(W|D|M|H)|PT([1-9]|[1-9][0-9])H)`)
var str = `P10M`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}