using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+)(?:=((?:\{[^}]+\}|""[^""\\]*(?:\\.[^""\\]*)*""|\w+)))?";
string input = @"key,key1=value1,key2={foo,bar},key3=""some description for \""foo\""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}