import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\w+)(?:=((?:\\{[^\\}]+\\}|\"[^\"\\\\]*(?:\\\\.[^\"\\\\]*)*\"|\\w+)))?";
final String string = "key,key1=value1,key2={foo,bar},key3=\"some description for \\\"foo\\\"\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}