$re = '/https?:\/\/(?:www.)?([^.]+)/m';
$str = 'https://regex101.com
https://regex_101.com
https://regex-101.com
https://regex.101.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);