re = /https?:\/\/(?:www.)?([^.]+)/m
str = 'https://regex101.com
https://regex_101.com
https://regex-101.com
https://regex.101.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end