package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\p{Sc}`)
var str = `Prices: $2, €1, ¥9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}