$re = '/\p{Sc}/m';
$str = 'Prices: $2, €1, ¥9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);