import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BEGIN:VEVENT([\\s\\S](?!BEGIN:VEVENT))+?sdf[\\s\\S]+?END:VEVENT";
final String string = "BEGIN:VEVENT\n"
+ "LAST-MODIFIED:20140203T092537Z\n"
+ "CREATED:20140101T161157Z\n"
+ "DTSTART:20140220T150000Z\n"
+ "DTSTAMP:20140203T092537Z\n"
+ "DTEND:20140220T170000Z\n"
+ "SUMMARY:Summary of Event\n"
+ "UID:appointment_27140\n"
+ "END:VEVENT\n\n"
+ "BEGIN:VEVENT\n"
+ "LAST-MODIFIED:20140203T092537Z\n"
+ "CREATED:20140101T161157Z\n"
+ "DTSTART:20140221T070000Z\n"
+ "DTSTAMP:20140203T092537Z\n"
+ "DTEND:20140221T130000Z\n"
+ "SUMMARY:Event 2\n"
+ "UID:appointment_27135\n"
+ "LOCATION:TINF11B2\n"
+ "END:VEVENT\n\n"
+ "BEGIN:VEVENT\n"
+ "LAST-MODIFIED:20140203T092537Z\n"
+ "CREATED:20140101T161157Z\n"
+ "DTSTART:20140221T070000Z\n"
+ "DTSTAMP:20140203T092537Z\n"
+ "DTEND:20140221T130000Z\n"
+ "SUMMARY:asd\n"
+ "UID:appointment_27135\n"
+ "LOCATION:TINF11B2\n"
+ "END:VEVENT\n\n"
+ "BEGIN:VEVENT\n"
+ "LAST-MODIFIED:20140203T092537Z\n"
+ "CREATED:20140101T161157Z\n"
+ "DTSTART:20140221T070000Z\n"
+ "DTSTAMP:20140203T092537Z\n"
+ "DTEND:20140221T130000Z\n"
+ "SUMMARY:sdf\n"
+ "UID:appointment_27135\n"
+ "LOCATION:TINF11B2\n"
+ "END:VEVENT\n\n"
+ "BEGIN:VEVENT\n"
+ "LAST-MODIFIED:20140203T092537Z\n"
+ "CREATED:20140101T161157Z\n"
+ "DTSTART:20140221T070000Z\n"
+ "DTSTAMP:20140203T092537Z\n"
+ "DTEND:20140221T130000Z\n"
+ "SUMMARY:dfg\n"
+ "UID:appointment_27135\n"
+ "LOCATION:TINF11B2\n"
+ "END:VEVENT";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}