# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"BEGIN:VEVENT([\s\S](?!BEGIN:VEVENT))+?sdf[\s\S]+?END:VEVENT"
test_str = ("BEGIN:VEVENT\n"
"LAST-MODIFIED:20140203T092537Z\n"
"CREATED:20140101T161157Z\n"
"DTSTART:20140220T150000Z\n"
"DTSTAMP:20140203T092537Z\n"
"DTEND:20140220T170000Z\n"
"SUMMARY:Summary of Event\n"
"UID:appointment_27140\n"
"END:VEVENT\n\n"
"BEGIN:VEVENT\n"
"LAST-MODIFIED:20140203T092537Z\n"
"CREATED:20140101T161157Z\n"
"DTSTART:20140221T070000Z\n"
"DTSTAMP:20140203T092537Z\n"
"DTEND:20140221T130000Z\n"
"SUMMARY:Event 2\n"
"UID:appointment_27135\n"
"LOCATION:TINF11B2\n"
"END:VEVENT\n\n"
"BEGIN:VEVENT\n"
"LAST-MODIFIED:20140203T092537Z\n"
"CREATED:20140101T161157Z\n"
"DTSTART:20140221T070000Z\n"
"DTSTAMP:20140203T092537Z\n"
"DTEND:20140221T130000Z\n"
"SUMMARY:asd\n"
"UID:appointment_27135\n"
"LOCATION:TINF11B2\n"
"END:VEVENT\n\n"
"BEGIN:VEVENT\n"
"LAST-MODIFIED:20140203T092537Z\n"
"CREATED:20140101T161157Z\n"
"DTSTART:20140221T070000Z\n"
"DTSTAMP:20140203T092537Z\n"
"DTEND:20140221T130000Z\n"
"SUMMARY:sdf\n"
"UID:appointment_27135\n"
"LOCATION:TINF11B2\n"
"END:VEVENT\n\n"
"BEGIN:VEVENT\n"
"LAST-MODIFIED:20140203T092537Z\n"
"CREATED:20140101T161157Z\n"
"DTSTART:20140221T070000Z\n"
"DTSTAMP:20140203T092537Z\n"
"DTEND:20140221T130000Z\n"
"SUMMARY:dfg\n"
"UID:appointment_27135\n"
"LOCATION:TINF11B2\n"
"END:VEVENT")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.