$re = '/^(?=.*\d)(?!.*?\.[^.\n]*,)\d*(,\d*,?)*(\.\d*)?$/m';
$str = '.0
0
1,0,0,0,
0.
1,,,,
.
,
.0,
.,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);