re = /^(?=.*\d)(?!.*?\.[^.\n]*,)\d*(,\d*,?)*(\.\d*)?$/m
str = '.0
0
1,0,0,0,
0.
1,,,,
.
,
.0,
.,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end