using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"KNAME=\""(.*)\"" FSTYPE=\""(.*)\"" SIZE=\""(.*)\"" MOUNTPOINT=\""(.)*\"" LABEL=\""(.*)\"" MODEL=\""(.*)\""";
string input = @"# lsblk -d -P -o KNAME,FSTYPE,SIZE,MOUNTPOINT,LABEL,MODEL
KNAME=""sda"" FSTYPE="" SIZE=""80G"" MOUNTPOINT="" LABEL="" MODEL=""VBOX HARDDISK ""
KNAME=""sda1"" FSTYPE="" SIZE=""243M"" MOUNTPOINT=""/boot"" LABEL="" MODEL=""
KNAME=""sda2"" FSTYPE="" SIZE=""1K"" MOUNTPOINT="" LABEL="" MODEL=""
KNAME=""sda5"" FSTYPE="" SIZE=""79.8G"" MOUNTPOINT="" LABEL="" MODEL=""
KNAME=""dm-0"" FSTYPE="" SIZE=""79G"" MOUNTPOINT=""/"" LABEL="" MODEL=""
KNAME=""dm-1"" FSTYPE="" SIZE=""768M"" MOUNTPOINT=""[SWAP]"" LABEL="" MODEL=""
KNAME=""sr0"" FSTYPE="" SIZE=""1024M"" MOUNTPOINT="" LABEL="" MODEL=""CD-ROM ""
KNAME=""sr1"" FSTYPE="" SIZE=""1024M"" MOUNTPOINT="" LABEL="" MODEL=""CD-ROM """;
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}