import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "KNAME=\\\"(.*)\\\" FSTYPE=\\\"(.*)\\\" SIZE=\\\"(.*)\\\" MOUNTPOINT=\\\"(.)*\\\" LABEL=\\\"(.*)\\\" MODEL=\\\"(.*)\\\"";
final String string = "# lsblk -d -P -o KNAME,FSTYPE,SIZE,MOUNTPOINT,LABEL,MODEL\n"
+ "KNAME=\"sda\" FSTYPE=\"\" SIZE=\"80G\" MOUNTPOINT=\"\" LABEL=\"\" MODEL=\"VBOX HARDDISK \"\n"
+ "KNAME=\"sda1\" FSTYPE=\"\" SIZE=\"243M\" MOUNTPOINT=\"/boot\" LABEL=\"\" MODEL=\"\"\n"
+ "KNAME=\"sda2\" FSTYPE=\"\" SIZE=\"1K\" MOUNTPOINT=\"\" LABEL=\"\" MODEL=\"\"\n"
+ "KNAME=\"sda5\" FSTYPE=\"\" SIZE=\"79.8G\" MOUNTPOINT=\"\" LABEL=\"\" MODEL=\"\"\n"
+ "KNAME=\"dm-0\" FSTYPE=\"\" SIZE=\"79G\" MOUNTPOINT=\"/\" LABEL=\"\" MODEL=\"\"\n"
+ "KNAME=\"dm-1\" FSTYPE=\"\" SIZE=\"768M\" MOUNTPOINT=\"[SWAP]\" LABEL=\"\" MODEL=\"\"\n"
+ "KNAME=\"sr0\" FSTYPE=\"\" SIZE=\"1024M\" MOUNTPOINT=\"\" LABEL=\"\" MODEL=\"CD-ROM \"\n"
+ "KNAME=\"sr1\" FSTYPE=\"\" SIZE=\"1024M\" MOUNTPOINT=\"\" LABEL=\"\" MODEL=\"CD-ROM \"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}