import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:..)+$)a+b+$";
final String string = "aabb\n"
+ "aabbb\n"
+ "abbb\n"
+ "aaabbb\n"
+ "aabb\n"
+ "abbbbb\n"
+ "abbbbb";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}