import Foundation
let pattern = #"^(?=(?:..)+$)a+b+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aabb
aabbb
abbb
aaabbb
aabb
abbbbb
abbbbb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)