import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ORDER NUMBER\\s*:\\s*\\S+\\s*Ship Date:\\s*\\S+\\s*Style Desc : .+\\s*Linecode\\s*: .+\\s*Qty\\s*.+";
final String string = "ORDER NUMBER : M0773175 Ship Date: 23-Nov-15\n\n"
+ " Style Desc : BLACKOUT CURTAINS CR 46X54\n"
+ " Linecode: M878966\n"
+ " Qty 36";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}