const regex = /ORDER NUMBER\s*:\s*\S+\s*Ship Date:\s*\S+\s*Style Desc : .+\s*Linecode\s*: .+\s*Qty\s*.+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ORDER NUMBER\\s*:\\s*\\S+\\s*Ship Date:\\s*\\S+\\s*Style Desc : .+\\s*Linecode\\s*: .+\\s*Qty\\s*.+', 'gi')
const str = `ORDER NUMBER : M0773175 Ship Date: 23-Nov-15
Style Desc : BLACKOUT CURTAINS CR 46X54
Linecode: M878966
Qty 36`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}