$re = '/ж[аоые]лезн[оыа][йи]?[ая] дв[ие]рь/';
$str = 'жылезныйя дверь
жылезныия дверь
жылезныя дверь';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);