re = /^()()((\[[^\]]*\]))\s*->(.*)/m
str = '[AAA] -> [BBB] -> [CCC]
AAA -> [BBB] -> [CCC]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end