package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:KON-[46-9]|HEW-[4-9]|CAN-[4-9])\d{4}$`)
var str = `KON-92382
KON-51234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}