$re = '/^(?:KON-[46-9]|HEW-[4-9]|CAN-[4-9])\d{4}$/m';
$str = 'KON-92382
KON-51234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);