package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\([^\\]*)(?:,|$)`)
var str = `\\lorem\ipsum\dolor,\\sit\amet\conseteteur,\\sadipscing\elitr\sed\diam`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}